Commandes de base sur CISCO OS

Dans cet article nous allons voir quelques commandes de base pour un switch/routeur CISCO.

Enregistrer la configuration active

Les modifications effectuées ne sont pas enregistré sur votre équipement CISCO. Pour les enregistrer

switch# write

Afficher la configuration active

Pour afficher la configuration complète de votre équipement

switch# show running-config

Modifier l'IP d'une interface

Dans mon exemple, je souhaite modifier l'IP du switch sur le Vlan1

switch> enable
switch> configure terminal
switch(config)# interface Vlan1
switch(config-if)# ip address 192.168.10.2 255.255.255.0
switch(config-if)# exit
switch(config)#

Ajouter une passerelle par défaut

Dans mon exemple, je souhaite définir la passerelle 10.17.200.254 comme passerelle par défaut

switch> enable
switch> configure terminal
switch(config)# ip default-gateway 10.17.200.254

Modifier un range de port

Dans mon exemple je souhaite modifier de la même manière le port 9-10-11

switch# enable
switch# configure terminal
switch(config)# interface range GigabitEthernet1/0/9 - 11

Afficher les différents TRUNK

Je souhaite afficher les différents TRUNK et voir les VLANs autorisés

switch> show interfaces trunk

Afficher le détail des VLANs

Permet d'afficher les VLANs déclarés sur le périphérique

switch# show vlan

Créer un VLAN

Dans mon exemple je souhaite créer le VLAN 220

switch> enable
switch# conf t
switch(config)# vlan 220
switch(config-vlan)# vlan 220

Supprimer un VLAN

Dans mon exemple je souhaite supprimer le VLAN 300

switch> enable
switch# conf t
switch(config)# vlan 300
switch(config-vlan)# no vlan 300

Réinitialiser par défaut une interface

Dans mon exemple je souhaite remettre par défaut les interfaces 1, 2, et 3

switch> enable
switch# conf t
switch(config)# default interface range GigabitEthernet1/0/1 - 3
 

Création d'un teaming/agrégation LACP

Dans mon exemple je souhaite créer une agrégation de deux ports (le 23 et le 24)

switch > enable
switch# conf t
switch(config)# interface range GigabitEthernet1/0/23 - 24
switch(config-if-range)# channel-group 1 mode active
switch(config-if-range)# channel-protocol lacp
switch(config-if-range)# exit

Ensuite, il suffit de configurer la nouvelle interface port-channel 1 suivant vos besoins

switch>enable
switch>configure terminal
switch(config)#interface port-channel 1
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk allowed vlan add 1,10,20
switch(config-if)#exit

Afficher le statut de toutes les interfaces

Switch> enable
Password: **********
Switch# show interfaces status

Afficher le statut d'une interface spécifique

Switch> enable
Password: **********
Switch# show interfaces Gi1/0/24 status

Désactiver une interface

Switch> enable
Password: **********
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gi1/0/23
Switch(config-if)# shutdown
Switch(config-if)# end
Switch#

Activer une interface

Switch> enable
Password: **********
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gi1/0/23
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch#

Afficher les informations matériels du switch

Switch> show version

Découvrir les équipements CISCO connectés au switch

Switch> show cdp neighbors

Pour obtenir plus de détails :

Switch> show cdp neighbors detail

Afficher les informations sur l'alimentation des ports PoE du switch

Switch> show power inline

Je compléterai la liste au fur et à mesure de mes besoins 🙂

 

1 commentaire sur “Commandes de base sur CISCO OS

  1. Roulet Reply

    Bonjour,

    J'aurai aimé savoir s'il existe une commade pour voir tous les ports d'un switch qui sont en mode TRUNK.
    En effet, j'ai une différence entre le "show interface statu" et le "show configuration"
    Certains ports apparaissent en show conf mais pas en int statu...

    Si vous avez une idée...
    Cdlt

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *